
 

บทที่ 3 
การเตรียมข้อมูล 

 
หลงัจากเก็บรวบรวมขอ้มูลท่ีเก่ียวขอ้งในงานวิจยัเรียบร้อยแลว้ ตอ้งตรวจสอบความ

ครบถว้นของขอ้มูลท่ีไดม้าเสียก่อน แลว้จึงวิเคราะห์ขอ้มูลซ่ึงในปัจจุบนัการวิเคราะห์ขอ้มูลส่วน
ใหญ่ใชโ้ปรแกรมส าเร็จรูปช่วยในการวเิคราะห์ขอ้มูล ดงันั้นผูว้ิจยัจะตอ้งน าขอ้มูลท่ีไดม้านั้นเตรียม
ใหพ้ร้อมแลว้จึววเิคราะห์ขอ้มูลต่อไป ซ่ึงขั้นตอนในการเตรียมขอ้มูลเพื่อการวเิคราะห์ขอ้มูลนั้น มี 3 
ขั้นตอน ดงัน้ี 

1. การสร้างคู่มือลงรหสั 
2. การสร้างแฟ้มขอ้มูล 
3. การตรวจสอบ และปรับปรุงขอ้มูล 

 

การสร้างคู่มือลงรหัส 
 

เม่ือเก็บรวบรวมขอ้มูลและตรวจสอบความครบถว้นของขอ้มูลท่ีเก่ียวขอ้งในงานวิจยั
แลว้ ก่อนการคียข์อ้มูลหรือสร้างแฟ้มขอ้มูลในโปรแกรมส าเร็จรูปทุกโปรแกรม จะตอ้งตั้งช่ือตวั
แปร ก าหนดรหัสให้กบัขอ้มูลเสียก่อนเพื่อความสะดวกในการคียข์อ้มูล ซ่ึงช่ือตวัแปรและรหัสท่ี
ก าหนดใหก้บัขอ้มูลนั้นจะเป็นตวัเลขหรือตวัอกัษรสั้น ๆ ในบางคร้ังอาจไม่ส่ือความหมาย และเป็น
สาเหตุท าใหห้ลงลืมช่ือตวัแปร และรหสัท่ีก าหนดข้ึนมาในภายหลงั ดงันั้นจึงตอ้งมีการจดบนัทึกช่ือ
ตวัแปรและรหสัท่ีก าหนดแลว้สร้างเป็นคู่มือการลงรหสั เพื่อเป็นคู่มือในการคียข์อ้มูลต่อไป 

โดยทัว่ไปในคู่มือการลงรหสัจะประกอบดว้ยช่ือตวัแปร (variable name) ชนิดของ
ค่าตวัแปร (variable type) ค าอธิบายความหมายของช่ือตวัแปร(variable label) ค  าอธิบายความหมาย
ของค่าตวัแปร (value label) ก าหนดค่าขอ้มูลท่ีไม่สมบูรณ์ (missing value) เป็นตน้ 

การตั้งช่ือตวัแปรและก าหนดรหสัของขอ้มูลนั้นจะก าหนดอยา่งไรข้ึนอยูก่บัขอ้มูลท่ี
รวบรวมมานั้นไดม้าจากเคร่ืองมือท่ีใชใ้นงานวจิยัเป็นแบบสอบถาม แบบทดสอบ หรือการทดลอง 
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1. ข้อมูลจากแบบสอบถาม 
 

ในกรณีท่ีเคร่ืองมือท่ีใช้ในงานวิจัยเป็นแบบสอบถาม โดยส่วนใหญ่จะให้ข้อ
ค าถาม 1 ขอ้เป็นตวัแปรขอ้มูล 1 ตวั ดงันั้นถา้มีขอ้ค าถาม 10 ขอ้ จะมีตวัแปรขอ้มูล 10 ตวั และรหสั
ของตวัแปรขอ้มูลแต่ละตวัคือตวัเลือกของขอ้ค าถามนั้น ๆ ดงัตวัอยา่ง 
 

ตัวอย่าง 3.1 ในการส ารวจปัญหาและอุปสรรคในปฏิบติังานท่ีไดรั้บมอบหมายของนกัศึกษา มหาวิทยาลยั
ราชภฏันครปฐม โดยใชแ้บบสอบถามซ่ึงประกอบดว้ยขอ้ค าถามดงัน้ี 
 

แบบสอบถาม 
เร่ือง  ปัญหาและอุปสรรคในปฏิบติังานท่ีไดรั้บมอบหมาย 

ของนกัศึกษาโปรแกรมวชิาคณิตศาสตร์ มหาวทิยาลยัราชภฏันครปฐม 
 
ตอนท่ี 1   ขอ้มูลทัว่ไปของผูต้อบแบบสอบถาม 
ค าช้ีแจง   โปรดท าเคร่ืองหมาย    ลงในช่อง    ท่ีตรงกบัความเป็นจริง 
 
1.   เพศ   

  1  ชาย   2  หญิง  
 

2.  ชั้นปีท่ีศึกษา 
  1.  ชั้นปีท่ี 2    2.  ชั้นปีท่ี 3     3.  ชั้นปีท่ี 4  

 

3. ในช่วงวนัจนัทร์-วนัศุกร์ ท่าน 

  1.  พกัท่ีหอพกั 
  2.  เดินทางไป-กลบับางวนั 
  3.  เดินทางไป-กลบัทุกวนั 

 

4.  โดยปกติท่านท างานท่ีไดรั้บมอบหมาย  
  1.  เสร็จทุกคร้ัง 
  2.  เสร็จเป็นส่วนใหญ่ 
  3.  เสร็จเป็นส่วนนอ้ย 
  4  ไม่เสร็จเลย 
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ตอนท่ี  2  ระดบัความส าคญัของอุปสรรคและปัญหาในการปฏิบติังานท่ีไดรั้บมอบหมาย 
 
ค าช้ีแจง โปรดท าเคร่ืองหมาย  ลงในช่องท่ีตรงกบัระดบัความส าคญัของปัญหาและอุปสรรคท่ี
ท่านไดรั้บจากการปฏิบติังานท่ีไดรั้บมอบหมายตามเกณฑ์ระดบัความส าคญัดงัน้ี 

5 หมายถึง ระดบัความส าคญัของปัญหาและอุปสรรคอยูใ่นระดบัมากท่ีสุด 
4 หมายถึง ระดบัความส าคญัของปัญหาและอุปสรรคอยูใ่นระดบัมาก 
3 หมายถึง ระดบัความส าคญัของปัญหาและอุปสรรคอยูใ่นระดบัปานกลาง 
2 หมายถึงระดบัความส าคญัของปัญหาและอุปสรรคอยูใ่นระดบันอ้ย 
1 หมายถึง ระดบัความส าคญัของปัญหาและอุปสรรคอยูใ่นระดบันอ้ยท่ีสุด 
 

ท่านประสบปัญหาและอุปสรรคในการปฏิบติังานท่ีไดรั้บมอบหมายในหวัขอ้ต่อไปน้ีในระดบัใด 
 

ปัญหาและอปุสรรคในการปฏิบติังานท่ีไดรั้บมอบหมาย 
ระดบัความส าคญั 

5 4 3 2 1 
1    จ านวนนกัศึกษามากเกินไป      
2    จ านวนวชิาเรียนมากเกินไป      
3    ความรู้พ้ืนฐานไม่เพียงพอ      
4    ขาดความรู้ความสามารถในการปฏิบติังาน      
5    มีกิจกรรมอ่ืนมากเกินไป      
6    แหล่งศึกษาคน้ควา้ไม่เพียงพอ      
7    งานท่ีไดรั้บมอบหมายมากเกินไป      
8    งานท่ีไดรั้บมอบหมายยากเกินไป      
9    ค  าช้ีแจงในการมอบงานไม่ชดัเจน      
10  ไม่สามารถบริหารเวลาไดอ้ยา่งเหมาะสม      
11  ขาดความกระตือรือร้นในการท างาน      
12  ไม่ไดรั้บความร่วมมือจากเพ่ือนในกลุ่ม(กรณีท างานกลุ่ม)      
13  งานท่ีไดรั้บมอบหมายมีความซ ้ าซอ้นกนัในแต่ละรายวชิา      
14  ติดต่อส่ือสารกบัผูส้อนไม่สะดวก      
15  ขาดแรงจูงใจในการปฏิบติังาน      
16  ผูส้อนใหค้ะแนนไม่เป็นธรรม      
17  ค่าใชจ่้ายในการปฏิบติังานสูงเกินไป      
 

จากแบบสอบถามขา้งตน้มีขอ้ค าถามทั้งหมด 21 ขอ้ ดงันั้นจะมีตวัแปรอยา่งน้อย 
21 ตวัแปร และมีการก าหนดรหสั ดงัน้ี 
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ช่ือตวัแปร 
(variable name) 

ชนิดของ 
ค่าตวัแปร 

(variable type) 

ค าอธิบายความหมายของ 
ช่ือตวัแปร 

(variable label) 

ค  าอธิบายความหมายของ 
ค่าตวัแปร 
(value label) 

id ตวัเลข แบบสอบถามฉบบัท่ี - 
gender ตวัเลข เพศ 1 = ชาย 

2 = หญิง 
9 = ค่าสูญหาย 

level ตวัเลข ชั้นปีท่ีศึกษา 1 = ชั้นปีท่ี 2 
2 = ชั้นปีท่ี 3 
3 = ชั้นปีท่ี 4 
9 = ค่าสูญหาย 

travel ตวัเลข การเดินทางในช่วงวนัจนัทร์-
วนัศุกร์ 

1 = พกัท่ีหอพกั 
2 = เดินทางไป-กลบับางวนั 
3 = เดินทางไป-กลบัทุกวนั 
9 = ค่าสูญหาย 

homework ตวัเลข การท างานท่ีไดรั้บมอบหมาย 1 = เสร็จทุกคร้ัง 
2 = เสร็จเป็นส่วนใหญ่ 
3 = เสร็จเป็นส่วนนอ้ย 
4 = ไม่เสร็จเลย 
9 = ค่าสูญหาย 

a1 

ตวัเลข 

ขอ้ค าถามท่ี 1 

5 = ระดบัมากท่ีสุด 
4 = ระดบัมาก 
3 = ระดบัปานกลาง 
2 = ระดบันอ้ย 
1 = ระดบันอ้ยท่ีสุด 
9 = ค่าสูญหาย 

a2 ขอ้ค าถามท่ี 2 
a3 ขอ้ค าถามท่ี 3 
a4 ขอ้ค าถามท่ี 4 
a5 ขอ้ค าถามท่ี 5 
a6 ขอ้ค าถามท่ี 6 
a7 ขอ้ค าถามท่ี 7 
a8 ขอ้ค าถามท่ี 8 
a9 ขอ้ค าถามท่ี 9 

a10 ขอ้ค าถามท่ี 10 
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ช่ือตวัแปร 
(variable name) 

ชนิดของ 
ค่าตวัแปร 

(variable type) 

ค าอธิบายความหมายของ 
ช่ือตวัแปร 

(variable label) 

ค  าอธิบายความหมายของ 
ค่าตวัแปร 
(value label) 

a11 ขอ้ค าถามท่ี 11 
a12 ขอ้ค าถามท่ี 12 
a13 ขอ้ค าถามท่ี 13 
a14 ขอ้ค าถามท่ี 14 
a15 ขอ้ค าถามท่ี 15 
a16 ขอ้ค าถามท่ี 16 
a17 ขอ้ค าถามท่ี 17 

 
ลกัษณะของแบบสอบถามท่ีตอบแลว้เป็นดงัน้ี 
 

ตอนท่ี 1   ขอ้มูลทัว่ไปของผูต้อบแบบสอบถาม 
ค าช้ีแจง   โปรดท าเคร่ืองหมาย    ลงในช่อง    ท่ีตรงกบัความเป็นจริง 
 
1.   เพศ   

  1  ชาย   2  หญิง  
2.  ชั้นปีท่ีศึกษา 

  1.  ชั้นปีท่ี 2    2.  ชั้นปีท่ี 3     3.  ชั้นปีท่ี 4  
3. ในช่วงวนัจนัทร์-วนัศุกร์ ท่าน 

  1.  พกัท่ีหอพกั 
  2.  เดินทางไป-กลบับางวนั 
  3.  เดินทางไป-กลบัทุกวนั 

4.  โดยปกติท่านท างานท่ีไดรั้บมอบหมาย  
  1.  เสร็จทุกคร้ัง 
  2.  เสร็จเป็นส่วนใหญ่ 
  3.  เสร็จเป็นส่วนนอ้ย 
  4  ไม่เสร็จเลย 
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ตอนท่ี  2  ระดบัความส าคญัของอุปสรรคและปัญหาในการปฏิบติังานท่ีไดรั้บมอบหมาย 
 

ท่านประสบปัญหาและอุปสรรคในการปฏิบติังานท่ีไดรั้บมอบหมายในหวัขอ้ต่อไปน้ีในระดบัใด 
 

ปัญหาและอปุสรรคในการปฏิบติังานท่ีไดรั้บมอบหมาย 
ระดบัความส าคญั 

5 4 3 2 1 
1    จ านวนนกัศึกษามากเกินไป      
2    จ านวนวชิาเรียนมากเกินไป      
3    ความรู้พ้ืนฐานไม่เพียงพอ      
4    ขาดความรู้ความสามารถในการปฏิบติังาน      
5    มีกิจกรรมอ่ืนมากเกินไป      
6    แหล่งศึกษาคน้ควา้ไม่เพียงพอ      
7    งานท่ีไดรั้บมอบหมายมากเกินไป      
8    งานท่ีไดรั้บมอบหมายยากเกินไป      
9    ค  าช้ีแจงในการมอบงานไม่ชดัเจน      
10  ไม่สามารถบริหารเวลาไดอ้ยา่งเหมาะสม      
11  ขาดความกระตือรือร้นในการท างาน      
12  ไม่ไดรั้บความร่วมมือจากเพ่ือนในกลุ่ม(กรณีท างานกลุ่ม)      
13  งานท่ีไดรั้บมอบหมายมีความซ ้ าซอ้นกนัในแต่ละรายวชิา      
14  ติดต่อส่ือสารกบัผูส้อนไม่สะดวก      
15  ขาดแรงจูงใจในการปฏิบติังาน      
16  ผูส้อนใหค้ะแนนไม่เป็นธรรม      
17  ค่าใชจ่้ายในการปฏิบติังานสูงเกินไป      
 

ลกัษณะของขอ้มูลดิบเป็นดงัน้ี 
 

 

ตวัแปร (Variable) 

ค่าสงัเกต 
(Case) 
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ค่าสงัเกต 
(Case) 

2. ข้อมูลจากแบบทดสอบ 
 

ในกรณีท่ีเคร่ืองมือท่ีใชใ้นงานวจิยัเป็นแบบทดสอบ โดยส่วนใหญ่จะให้ขอ้ค าถาม 
1 ขอ้เป็นตวัแปรขอ้มูล 1 ตวั ดงันั้นถา้มีขอ้ค าถาม 10 ขอ้ จะมีตวัแปรขอ้มูล 10 ตวั และรหสัของตวั
แปรขอ้มูลแต่ละตวัคือตวัเลือกของขอ้ค าถามนั้น ๆ ดงัตวัอยา่ง 
 

ตัวอย่าง 3.2 ในการสอบวิชาหลกัสถิติของนกัเรียน 20 คน ซ่ึงแบบทดสอบเป็นขอ้สอบปรนยั 5 
ตวัเลือก จ านวน 10 ขอ้ ลกัษณะขอ้สอบเป็นดงัน้ี 

1. ขอ้ความต่อไปน้ีขอ้ใดคือความหมายของค าวา่ ตวัอยา่ง (sample) ในทางสถิติ 
ก. กลุ่มของหน่วยแจงนบับางส่วนในประชากร 
ข. กลุ่มของหน่วยแจงนบัท่ีตอ้งการศึกษา 
ค. หน่วยแจงนบัซ่ึงเป็นแหล่งใหข้อ้เทจ็จริงทั้งหมด 
ง. หน่วยแจงนบัทุกหน่วยในประชากร 
จ. หน่วยแจงนบัท่ีตอ้งการศึกษา 

ส่วนขอ้สอบอีก 9 ขอ้มีลกัษณะเดียวกนั จากแบบทดสอบขา้งตน้มีขอ้ค าถามทั้งหมด 
10 ขอ้ ดงันั้นจะมีตวัแปร 10 ตวัแปรแต่ละตวัแปรมีการก าหนดรหสั 5 รหสั ดงัน้ี 

ช่ือตวัแปร 
(variable name) 

ชนิดของ 
ค่าตวัแปร 

(variable type) 

ค าอธิบายความหมายของ 
ช่ือตวัแปร 

(variable label) 

ค  าอธิบายความหมายของ 
ค่าตวัแปร 
(value label) 

no ตวัเลข แบบทดสอบของนกัเรียนคนท่ี - 
t1 – t10 ตวัเลข ขอ้สอบขอ้ท่ี 1 - 10 1 = ก    2 = ข    3 = ค    4 = ง 

5 = จ 
 

ลกัษณะของขอ้มูลดิบเป็นดงัน้ี 
 

 

ตวัแปร (Variable) 
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3. ข้อมูลจากการทดลอง 
 

ในกรณีท่ีเคร่ืองมือท่ีใช้ในงานวิจยัเป็นการทดลอง จะต้องมีการออกแบบการ
ทดลอง โดยทัว่ไปจะแบ่งได ้2 กรณี คือกรณีขอ้มูลท่ีไดจ้ากการทดลองมาจากการวดัซ ้ ากลุ่มทดลอง
เดิม ซ่ึงเรียกวา่กลุ่มทดลองไม่เป็นอิสระกนั และ กรณีขอ้มูลท่ีไดจ้ากการทดลองมาจากการวดักลุ่ม
ทดลองหลาย ๆ กลุ่ม ซ่ึงเรียกวา่กลุ่มทดลองเป็นอิสระกนั การสร้างตวัแปรและการก าหนดรหสัจะ
แตกต่างกนั ดงัตวัอยา่งดงัน้ี 

3.1 กรณีกลุ่มทดลองไม่เป็นอิสระกนั จะก าหนดตวัแปรขอ้มูลตามจ านวนการวดั
ซ ้ า ดงันั้นถา้มีกลุ่มทดลองเดียวแต่วดัขอ้มูลซ ้ า 2 คร้ังจะมีตวัแปรขอ้มูล 2 ตวัดงัตวัอยา่ง 
 

ตัวอย่าง 3.3 ในการทดสอบความสามารถของนกัเรียนในการคิดค านวณคณิตศาสตร์โดยใชว้ิธีการ
คิดในใจ 2 วธีิ จึงท าการใหน้กัเรียนแกปั้ญหาโจทยข์อ้เดียวกนั แต่ใชว้ธีิการคิด 2 วิธี  แลว้จบัเวลาใน
การคิด (วนิาที) ไดผ้ลดงัน้ี 

 เวลาท่ีใชใ้นการคิด (วินาที) 
คนท่ี วธีิท่ี 1 วธีิท่ี 2 

1 55 50 
2 46 42 
3 78 70 
4 61 63 
5 52 58 
6 45 35 
7 47 46 
8 57 52 
9 71 60 

10 58 49 
 

ในการทดลองน้ีกลุ่มทดลองใช้นักเรียน 10 คน แก้ปัญหาโจทยข์อ้เดียวกนัแต่ใช้
วธีิการคิด 2 วธีิ ดงันั้นกลุ่มทดลองน้ีถูกวดัเวลาในการคิดค านวณซ ้ า 2 คร้ัง เป็นกลุ่มทดลองท่ีไม่เป็น
อิสระกนั  

ดงันั้นจะมีตวัแปร2 ตวัแปร และไม่มีการก าหนดรหสั ดงัน้ี 
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ค่าสงัเกต 
(Case) 

ช่ือตวัแปร 
(variable name) 

ชนิดของ 
ค่าตวัแปร 

(variable type) 

ค าอธิบายความหมายของ 
ช่ือตวัแปร 

(variable label) 

ค  าอธิบายความหมายของ 
ค่าตวัแปร 
(value label) 

no ตวัเลข นกัเรียนคนท่ี - 
time1 ตวัเลข เวลาท่ีใชใ้นการคิดของวธีิท่ี 1 - 
time2 ตวัเลข เวลาท่ีใชใ้นการคิดของวธีิท่ี 2 - 

 
ลกัษณะของขอ้มูลดิบเป็นดงัน้ี 
 

 
 

3.2 กรณีกลุ่มทดลองเป็นอิสระกนั จะก าหนด 2 ตวั คือตวัแปรแบ่งกลุ่ม 1 ตวั และ
ตวัแปรขอ้มูล 1 ตวั โดยก าหนดรหสัของตวัแปรแบ่งกลุ่มตามจ านวนกลุ่มทดลอง ตวัดงัตวัอยา่ง 
 

ตัวอย่าง 3.3 ในการทดสอบผลสัมฤทธ์ิทางการเรียนคณิตศาสตร์ เร่ืองเศษส่วนของนกัเรียนกลุ่มท่ีใช้
กิจกรรมการเรียนรู้ตามแนวทฤษฎีคอนสตรัคติวิสต์สูงกวา่นกัเรียนกลุ่มท่ีเรียนตามวิธีปกติหรือไม่ 
จึงท าการทดลองแบ่งนกัเรียนท่ีมีลกัษณะคลา้ย ๆ กนัออกเป็น 2 กลุ่ม กลุ่ม 1 จ านวน 12 คน เรียน
เร่ืองเศษส่วนโดยใชกิ้จกรรมการเรียนรู้ตามแนวทฤษฎีคอนสตรัคติวิสต ์ส่วนกลุ่ม 2 จ านวน 10 คน
เรียนเร่ืองเดียวกนั แต่ใชว้ิธีปกติ เม่ือจบเน้ือหาจึงทดสอบดว้ยแบบทดสอบคะแนนเต็ม 20 คะแนน 
ไดผ้ลดงัน้ี 

กิจกรรมการเรียนรู้ 
คะแนนสอบของนกัเรียน 

1 2 3 4 5 6 7 8 9 10 11 12 
ทฤษฎีคอนสตรัคติวสิต ์ 14 13 14 15 14 13 15 18 17 15 16 18 
วธีิปกติ 11 12 12 10 13 11 11 12 15 13   

ตวัแปร (Variable) 
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ค่าสงัเกต 
(Case) 

ในการทดลองน้ีใช้กลุ่มทดลองเป็นนักเรียน 2 กลุ่ม โดยกลุ่มท่ี 1 ใช้กิจกรรมการ
เรียนรู้ตามแนวทฤษฎีคอนสตรัคติวิสต์ ส่วนกลุ่ม 2 ใชกิ้จกรรมการเรียนรู้ตามวิธีปกติ ดงันั้นกลุ่ม
ทดลองน้ีถูกวดัคะแนนแยกจากกนั เป็นกลุ่มทดลองท่ีเป็นอิสระกนั ดงันั้นจะมีตวัแปร2 ตวัแปร คือ
ตวัแปรกลุ่มท่ี และตวัแปรขอ้มูล ดงัน้ี 

 

ช่ือตวัแปร 
(variable name) 

ชนิดของ 
ค่าตวัแปร 

(variable type) 

ค าอธิบายความหมายของ 
ช่ือตวัแปร 

(variable label) 

ค  าอธิบายความหมายของ 
ค่าตวัแปร 
(value label) 

id ตวัเลข นกัเรียนคนท่ี - 
group ตวัเลข กลุ่มกิจกรรมการเรียนรู้ 1 = ทฤษฎีคอนสตรัคติวสิต์ 

2 = วธีิปกติ 
score ตวัเลข คะแนนท่ีได ้ - 

 

ลกัษณะของขอ้มูลดิบเป็นดงัน้ี 
 

 

ตวัแปร (Variable) 
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การสร้างแฟ้มข้อมูล 
 

การสร้างแฟ้มขอ้มูลเป็นการบนัทึกขอ้มูลดิบจากแบบสอบถาม แบบทดสอบ หรือการ
ทดลอง เขา้สู่โปรแกรมส าเร็จรูปท่ีตอ้งการใชใ้นการวิเคราะห์ขอ้มูล โดยจะมีการสร้างตวัแปร และ
รหัสตามคู่มือการลงรหัสท่ีสร้างในขั้นท่ี 1 โปรแกรมส าเร็จรูปแต่ละโปรแกรมมีวิธีการสร้าง
แฟ้มขอ้มูลท่ีแตกต่างกนั ในเอกสารฉบบัน้ีจะกล่าวรายละเอียดเฉพาะโปรแกรม SPSS for Window 
และ Microsoft Excel เท่านั้น 

 

1. การสร้างแฟ้มข้อมูลใน SPSS for Window 
 

การบนัทึกขอ้มูลเขา้โปรแกรม SPSS for Window นั้นเร่ิมตน้ดว้ยการเขา้สู่การ
ท างานโปรแกรม SPSS จะปรากฏหนา้ต่าง ดงัรูป  

 

    
 
ถา้มีแฟ้มขอ้มูลท่ีสร้างเรียบร้อยแลว้ (นามสกุล .sav) และตอ้งการเรียกแฟ้มขอ้มูล

มาใช้ให้เลือก More Files… ในส่วนของ Open an existing data source แลว้จึงเลือกช่ือไฟล์ท่ี
ตอ้งการ แต่ในกรณีตอ้งการสร้างแฟ้มขอ้มูลให้คลิก Cancel จะปรากฏหนา้ต่าง SPSS Data Editor 
ดงัรูป 
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คลิกท่ี Variable View Tab หนา้ต่าง SPSS Data Editor จะเปล่ียนไปท างานในส่วน

ของการก าหนดตวัแปร ดงัรูป 

 
 
ความหมายของแต่ละคอลมัภข์อง Variable View เป็นดงัน้ี 
1. คอลมัภ ์Name ใชก้ าหนดช่ือตวัแปร 
2. คอลมัภ ์Type ใชก้ าหนดชนิดของตวัแปร เช่น ตวัเลข (Numeric) ตวัอกัษร (String) 
3 คอลมัภ ์Width ก าหนดความกวา้งส าหรับเก็บค่าของตวัแปร 
4. คอลมัภ ์Decimals ก าหนดต าแหน่งทศนิยมของขอ้มูลตวัเลข 
5. คอลมัภ ์Label ก าหนดค าอธิบายช่ือของตวัแปร 
6. คอลมัภ ์Values ก าหนดความหมายใหก้บัค่าตวัเลขรหสั  
7. คอลมัภ ์Missing ก าหนดรหสัค่าสูญหายเช่น 9 หมายถึงค่าสูญหาย 
8. คอลมัภ ์Columns ก าหนดความกวา้งของ Columns ใน Data View 
9. คอลมัภ ์Align ก าหนดการแสดงผลใน Column เป็น ชิดซา้ย ชิดขวา หรือ ก่ึงกลาง 
10. คอลมัภ ์Measure ก าหนดชนิดขอ้มูลเป็น Scale, Ordinal, Nominal 
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ตัวอย่าง 3.5 จากคู่มือการลงรหสัในตวัอย่าง 3.1 จะก าหนดค่าต่าง ๆ ของตวัแปร id  gender และ 
level ดงัน้ี 

1. การก าหนดค่าต่าง ๆ ของตวัแปร id 
 
ขั้นท่ี 1. พิมพช่ื์อตวัแปร id ในคอลมัภ ์Name ของตวัแปรตวัท่ี 1 

 
 
เม่ือกด Enter โปรแกรมจะน าค่า Default ของ SPSS เก่ียวกบัตวัแปรมาเติมให้ ซ่ึงจะ

ไดผ้ลเป็นดงัน้ี 

 
 

จากคู่มือการลงรหสั ค่าต่าง ๆ ของตวัแปร id  gender และ level เป็นดงัน้ี 
ช่ือตวัแปร 

(variable name) 
ชนิดของ 
ค่าตวัแปร 

(variable type) 

ค าอธิบายความหมายของ 
ช่ือตวัแปร 

(variable label) 

ค  าอธิบายความหมายของ 
ค่าตวัแปร 
(value label) 

id ตวัเลข แบบสอบถามฉบบัท่ี - 
gender ตวัเลข เพศ 1 = ชาย 

2 = หญิง 
9 = ค่าสูญหาย 

level ตวัเลข ชั้นปีท่ีศึกษา 1 = ชั้นปีท่ี 2 
2 = ชั้นปีท่ี 3 
3 = ชั้นปีท่ี 4 
9 = ค่าสูญหาย 
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ขั้นท่ี 2 พิมพค์่าท่ีตอ้งการในแต่ละ Column ของตวัแปร id หรือคลิกท่ี   

ในคอลมัภ ์Type จะปรากฏหนา้ต่าง Variable Type ดงัรูป 

 
 
ในหนา้ต่าง Variable Type เราสามารถเลือกชนิดของตวัแปรเป็น Numeric, String, ...

สามารถก าหนดความกวา้งในช่อง Width และการแสดงผลทศนิยมในช่อง Decimal Places เช่น
ก าหนดความกวา้งเป็น 3 ก าหนดการแสดงผลทศนิยมเป็น 0 ต าแหน่ง ดงัรูป  

 
 
หลงัจากเลือก OK จะปรากฏค่าความกวา้งและการแสดงผลทศนิยมตรงกบัท่ีก าหนด

ในหนา้ต่าง Variable Type ดงัรูป (หรือจะก าหนดค่า Width และ Decimal ในคอลมัภ ์Width และ 
Decimal ก็ได)้ 
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ขั้นท่ี 3 พิมพค์  าอธิบายความหมายช่ือของตวัแปรในคอลมัภ ์Label ดงัรูป 

 
 

ขั้นท่ี 4 ก าหนดค่ารหสัของตวัแปรโดยเลือกท่ี  ในคอลมัภ ์Values จะ
ปรากฏหนา้ต่าง Value Label ดงัรูป (กรณีตวัแปร id ไม่มีการก าหนดรหสัจึงเลือก Cancel) 

 

 
 

ขั้นท่ี 5 ก าหนดรหัสค่าสูญหายโดยเลือกท่ี    ในคอลมัภ์ Missing จะ
ปรากฏหนา้ต่าง Missing Values ดงัรูป (กรณีตวัแปร id ไม่มีการก าหนดรหสัจึงเลือก Cancel) 

 
 

ขั้นท่ี 6 ก าหนดความกวา้งของคอลมัภท่ี์จะแสดงผลในมุมมอง Data View ในคอลมัภ ์
Columns เป็น 5 (ค่าท่ีก าหนดไม่ควรนอ้ยกวา่ค่า Width)  
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ขั้นท่ี 7 ก าหนดการแสดงผลโดยเลือก       ในคอลมัภ ์Align เป็น ชิดซ้าย 
(Left) ชิดขวา (Right) หรือ ก่ึงกลาง (Center) ในท่ีน้ีเลือก Left 

ขั้นท่ี 8 ก าหนดระดับการวดัของขอ้มูลโดยเลือก     ในคอลมัภ์ Measure 
เป็นระดบัการวดัอนัตรภาคและอตัราส่วน (Scale) ระดบัการวดัเรียงอนัดบั (Ordinal) และระดบัการ
วดันามบญัญติั (Nominal) ในท่ีน้ีเลือก Nominal 

จะไดผ้ลลพัธ์ ดงัรูป 

 
 

2. การก าหนดค่าต่าง ๆ ของตวัแปร gender และ level  
   ด าเนินการตามขั้นท่ี 1 – 8 เหมือนกบัตวัแปร id ดงัรูป 

 
แต่ในคอลมัภ ์Values และ Missing จะก าหนดค่ารหสัตวัแปร ดงัน้ี 
ในคอลมัภ ์Values ของตวัแปร gender ในหนา้ต่าง Value Label พิมพร์หสั 1 ในช่อง 

Value และพิมพ ์ชาย ในช่อง Value Label เลือก Add โปรแกรมจะเพิ่มรหสัตวัแปรไวใ้นโปรแกรม 
ดงัรูป     
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พิมพร์หสั 2 ในช่อง Value และพิมพ ์หญิง ในช่อง Value Label เลือก Add โปรแกรม
จะเพิ่มรหสัตวัแปรไวใ้นโปรแกรม ดงัรูป แลว้เลือก OK  

       
 

ในคอลมัภ ์Values ของตวัแปร level ในหนา้ต่าง Value Label  
พิมพร์หสั 1 ในช่อง Value และพิมพ ์ชั้นปีท่ี 2 ในช่อง Value Label เลือก Add  
พิมพร์หสั 2 ในช่อง Value และพิมพ ์ชั้นปีท่ี 3 ในช่อง Value Label เลือก Add  
พิมพร์หสั 3 ในช่อง Value และพิมพ ์ชั้นปีท่ี 4 ในช่อง Value Label เลือก Add 
โปรแกรมจะเพิ่มรหสัตวัแปรไวใ้นโปรแกรม ดงัรูป แลว้เลือก OK    

 
 

ในคอลมัภ์ Missing ของตวัแปร gender ในหน้าต่าง Missing Values มีตวัเลือก 3 
ตวัเลือก คือ 

-  No missing values หมายถึงตวัแปรน้ีไม่มีค่า Missing values 
- Discrete missing values หมายถึงตวัแปรน้ีมีค่า Missing เป็นตวัเลขท่ีก าหนด 
- Range plus one optional discrete missing values ตวัแปรน้ีมีค่า Missing แบบผสม

ทั้งชนิดเป็นช่วงและเป็นค่าแบบ discrete อีก 1 ค่า 
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ส าหรับตวัแปร gender และ level เลือกชนิด Missing เป็น Discrete missing value 
และพิมพค์่าในช่องเป็นเลข 9 เสร็จแลว้คลิก OK 

 
 
บนจอภาพจะกลบัไปท่ี SPSS Data Editor ในส่วน Variable View 

 
 

ส าหรับตวัแปรท่ีเหลือด าเนินการเช่นเดียวกนัจะปรากฏหนา้ต่าง Variable View ดงัรูป 
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จากนั้นเลือก Data View Tab เพื่อคียข์อ้มูลตามตารางขอ้มูลดิบ ดงัผลดงัน้ี 

 
 
เลือกเมนู File > Save ใส่ช่ือไฟล ์เลือก OK 
 

2. การสร้างแฟ้มข้อมูลใน Microsoft Excel 
 

การบนัทึกขอ้มูลเขา้โปรแกรม Microsoft Excel นั้นเร่ิมตน้ดว้ยการเขา้สู่การท างาน
โปรแกรม Excel จะปรากฏหนา้ต่าง ดงัรูป  

 
สร้างตงัแปรไวใ้นบรรทดัท่ี 1 ของ work sheet และคียข์อ้มูลตามตารางขอ้มูลดิบ 
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ตวัอยา่ง 3.6 จากตวัอยา่ง 3.1 การสร้างแฟ้มขอ้มูลใน Microsoft Excel มีขั้นตอน ดงัน้ี 
ขั้นท่ี 1 สร้างตวัแปรตามคู่มือลงรหสัไวท่ี้บรรทดัท่ี 1 ดงัรูป 

 
 

ขั้นท่ี 2 คียข์อ้มูลดิบตามตาราง จะไดผ้ลลพัธ์ ดงัรูป 

 
 

เลือกเมนู File > Save ใส่ช่ือไฟล ์เลือก OK 
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การปรับปรุงข้อมูล 
 

เม่ือสร้างแฟ้มขอ้มูลแลว้ก่อนการวิเคราะห์ขอ้มูลควรตรวจสอบเสียก่อนวา่ขอ้มูลท่ีคีย์
ไปแลว้นั้นมีรหสัหรือขอ้มูลท่ีคียผ์ิดหรือไม่ ถา้มีตอ้งแกไ้ขให้ถูกตอ้งเสียก่อน และในบางคร้ังอาจ
ตอ้งมีการปรับปรุงขอ้มูล หรือตวัแปรก่อนท่ีจะมีการิเคราะห์ขอ้มูลต่อไป การปรับปรุงขอ้มูลนั้นมี
หลายวธีิ ในเอกสารฉบบัน้ีจะกล่าวรายละเอียดในการปรับปรุงขอ้มูล 3 ลกัษณะ ดงัน้ี 

1. การเพิ่ม การแทรก การลด การรวม ตวัแปร (variable) และค่าสังเกต (case) 
2. การสร้างตวัแปรใหม่จากตวัแปรเดิม 
3. การเปล่ียนรหสัของตวัแปร 
 

1. การเพิม่ การแทรก การลด การรวม ตัวแปรและ ค่าสังเกต 
 

การท างานกบัแฟ้มขอ้มูลเราอาจจะตอ้งท าการเพิ่มเติมกบัแฟ้มขอ้มูลคือ การเพิ่ม การ
แทรก การลด การรวม ตวัแปรและค่าสังเกต 

1.1 การเพิ่ม การแทรก ตัวแปร และค่าสังเกต เป็นการเพิ่มหรือแทรกตวัแปรหรือค่า
สังเกตในแฟ้มขอ้มูลท่ีมีอยูแ่ลว้โดยเลือกเมนู Data > Insert Variable ถา้ตอ้งการเพิ่มหรือแทรกตวั
แปร และเลือกเมนู Data > Insert Cases ถา้ตอ้งการเพิ่มหรือแทรกค่าสังเกต หรือจะใชว้ิธีเล่ือนเมาส์
ไปคลิกท่ีหัวคอลมัภข์องตวัแปร หรือหัวแถวของค่าสังเกตแลว้คลิกขวา เลือก Insert Variable ถา้
ตอ้งการเพิ่มหรือแทรกตวัแปร และเลือกเมนู Insert Cases ถา้ตอ้งการเพิ่มหรือแทรกค่าสังเกต โดย
จะเพิ่มหรือแทรกตวัแปรหรือค่าสังเกตหนา้ตวัแปรหรือค่าสังเกตท่ีเลือก 
 
ตวัอยา่ง 3.7 ตอ้งการแทรกตวัแปร t ระหว่างตวัแปร x และ y ในแฟ้มขอ้มูล file_xy1.sav และ
บนัทึกเป็นช่ือ file_xty.sav 
  file_xy1.sav      file_xty.sav 
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ขั้นท่ี 1. เปิดแฟ้มขอ้มูล file_xy1.sav เล่ือนเมาส์ไปคลิกท่ีหวั column ของตวัแปร y 

   
 
ขั้นท่ี 2. เลือกเมนู Data > Insert Variable บนจอภาพจะแทรกช่องตวัแปร var00001 

ระหวา่งแปร x และ y 

   
 

ขั้นท่ี 3. บนัทึกขอ้มูลและ save เป็นช่ือ file_xty.sav 
 

ตวัอยา่ง 3.8 แทรกค่าสังเกตระหว่างค่าสังเกตตวัท่ี 2 และ 3 ในแฟ้มขอ้มูล file_xy1.sav โดยให้ค่า
สังเกต x = 5 และ y = 19 แลว้บนัทึกเป็นช่ือ file_xy1 6obs.sav 
 

   
 
  



 87 

ขั้นท่ี 1. เปิดแฟ้มขอ้มูล xy1.sav แลว้เล่ือนเมาส์ไปคลิกท่ีหวัแถวท่ี 3 

   
 

ขั้นท่ี 2 เลือกเมนู Data > Insert Case 

  
 

ขั้นท่ี 3 พิมพค์่า x = 5 และ y = 19 

 
 
ขั้นท่ี 4  บนัทึกไวท่ี้ช่ือ file_xy1 6obs.sav 
 
1.2 การลดตัวแปร และค่าสังเกต เป็นการลบตวัแปรหรือค่าสังเกตในแฟ้มขอ้มูลท่ีมีอยู่

แลว้โดยคลิกท่ีหวัคอลมัภข์องตวัแปร หรือหวัแถวของค่าสังเกตท่ีตอ้งการลบ แลว้เลือกเมนู Edit > 
Clear หรือกดปุ่ม Del บนคียบ์อร์ด หรือจะใชว้ิธีเล่ือนเมาส์ไปคลิกท่ีหวัคอลมัภข์องตวัแปร หรือหวั
แถวของค่าสังเกตแลว้คลิกขวา เลือก Clear ก็ได ้
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ตวัอยา่ง 3.9 ตอ้งการลดตวัแปร y ออกจากแฟ้มขอ้มูล file_xty.sav  
 

 
 
ขั้นท่ี 1. เปิดแฟ้มขอ้มูล file_xty.sav แลว้คลิกท่ีช่องตวัแปร y 

   
 
ขั้นท่ี 2.กด Del จะไดว้า่ตวัแปร y หายไป 

 
 

ตวัอยา่ง 3.10 ตอ้งการลดค่าสังเกตท่ี 5 ออกจากแฟ้มขอ้มูล file_xy1 6obs.sav  
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ขั้นท่ี 1. เปิดแฟ้มขอ้มูล file_xt1 6obs.sav แลว้คลิกท่ีหวัแถวท่ี 5 

   
ขั้นท่ี 2.กด Del จะไดว้า่ค่าสังเกตท่ี 5 หายไป และ เล่ือนค่าสังเกตตวัท่ี 6 ข้ึนมาเป็นค่า

สังเกตตวัท่ี 5 

 
 

1.3 การรวมตัวแปรหรือค่าสังเกต เป็นการรวมตวัแปรหรือค่าสังเกตของแฟ้มขอ้มูล 2 
แฟ้มเขา้ดว้ยกนั โดยมีเง่ือนไขวา่ในการรวมตวัแปรนั้นแฟ้มขอ้มูล 2 แฟ้มจะตอ้งมีช่ือตวัแปรต่างกนั
จึงจะสามารถน าตวัแปรมารวมเป็นแฟ้มเดียวกนัได ้โดยเลือกเมนู Data > Merge Files > Add 
Variables…และในการรวมค่าสังเกตนั้นแฟ้มขอ้มูล 2 แฟ้มจะตอ้งมีช่ือตวัแปรและโครงสร้างของ
ตวัแปรท่ีเหมือนกนัจึงจะสามารถน าค่าสังเกตมารวมเป็นแฟ้มเดียวกนัได้ โดยเลือกเมนู Data > 
Merge Files > Add Cases… 
 
ตวัอยา่ง 3.11 ใหร้วมตวัแปรในแฟ้มขอ้มูล file_xy1.sav และ file_zw.sav แลว้บนัทึกเป็นแฟ้มขอ้มูล
ช่ือ file_xyzw.sav 
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ขั้นท่ี 1 เปิดแฟ้มขอ้มูล file_xy1.sav เลือกเมนู Data > Merge Files > Add Variables 

   
 
ขั้นท่ี 2 เลือกแฟ้มขอ้มูล file_zw.sav แลว้คลิก Open จะปรากฏหนา้ต่าง Add Variable  

 
 

ในส่วนของ Exclude Variables: จะแสดงช่ือตวัแปรท่ีซ ้ ากนัของแฟ้มขอ้มูลท่ีเปิดอยู ่
และในส่วนของ New Working Data File: จะแสดงช่ือตวัแปรท่ีรวมกนัเป็นแฟ้มขอ้มูลใหม่ (ใน
กรณีน้ีทั้ง 2 แฟ้มไม่มีตวัแปรซ ้ ากนัจึงไม่ปรากฏช่ือตวัแปรในช่อง Exclude Variables) 

เลือก OK จะไดแ้ฟ้มขอ้มูล ดงัน้ี 
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ตวัอยา่ง 3.12 ใหร้วมตวัแปรในแฟ้มขอ้มูล file_xy1.sav และ file_xy2.sav  
 

   
 

ขั้นท่ี 1 เปิดแฟ้มขอ้มูล file_xy1.sav เลือกเมนู Data > Merge Files > Add Cases 

   
 

ขั้นท่ี 2 เลือกแฟ้มขอ้มูล file_xy2.sav แลว้คลิก Open จะปรากฏหนา้ต่าง Add Cases 

 
 
ในส่วนของ Unpaired Variables จะแสดงช่ือตวัแปรท่ีไม่เหมือนกบัแฟ้มขอ้มูลท่ีเปิด

อยู ่ ในส่วนของ Variables in New Working Data File: จะแสดงช่ือตวัแปรท่ีรวมค่าสังเกตกนัเป็น
แฟ้มขอ้มูลใหม่ (ในกรณีน้ีทั้ง 2 แฟ้มไม่มีตวัแปรท่ีไม่เหมือนกนัจึงไม่ปรากฏช่ือตวัแปรในช่อง 
Unpaired Variables) 
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เลือก OK จะไดแ้ฟ้มขอ้มูล ดงัน้ี 
 

 
 

 

2. การสร้างตัวแปรใหม่จากตัวแปรเดิม 
 

เป็นการสร้างตวัแปรใหม่จากตวัแปรท่ีมีอยูแ่ลว้ดว้ยการด าเนินการทางคณิตศาสตร์ 
เช่นการบวก ลบ คูณ หาร เป็นตน้ โดยการเขียนสูตรการค านวณ หรือเรียกใชฟั้งกช์ัน่ท่ีเก่ียวขอ้งก็ได้
โดยเลือกเมนู Transform > Compute 
 
ตวัอยา่ง 3.13 จากแฟ้มขอ้มูล file_xy1.sav ใหส้ร้างตวัแปร xplusy = x+y  
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ขั้นท่ี 1 เปิดแฟ้มขอ้มูล file_xy1.sav เลือกเมนู Transform > Compute 

   
 

ขั้นท่ี 2 ในหนา้ต่าง Compute Variable ใส่ช่ือตวัแปรใหม่ในช่อง Target Variable และ
ใส่การด าเนินการทางคณิตศาสตร์โดยพิมพใ์นช่อง Numeric Expression หรือเลือกตวัแปรในช่อง
ดา้นซา้ยก็ได ้ดงัรูป (สามารถเรียกใชฟั้งกช์ัน่ท่ีเก่ียวขอ้งในช่อง Functions) 

 
 
เลือก OK จะไดผ้ลลพัธ์ ดงัน้ี 
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ตวัอยา่ง 3.14 จากแฟ้มขอ้มูล file_xy1.sav ใหส้ร้างตวัแปร lnx = ln(x)  
ขั้นท่ี 1 เปิดแฟ้มขอ้มูล file_xy1.sav เลือกเมนู Transform > Compute 
ขั้นท่ี 2 ในหนา้ต่าง Compute Variable ใส่ช่ือตวัแปรใหม่ในช่อง Target Variable และ

ใส่การด าเนินการทางคณิตศาสตร์โดยพิมพใ์นช่อง Numeric Expression หรือเลือกตวัแปรในช่อง
ดา้นซา้ยก็ได ้ดงัรูป สามารถเรียกใชฟั้งกช์ัน่ท่ีเก่ียวขอ้งในช่อง Functions) 

 
 
เลือก OK จะไดผ้ลลพัธ์ ดงัน้ี 

 
 

3. การเปลีย่นรหัสตัวแปร 
 

เป็นการเปล่ียนรหสัของตวัแปรจากรหสัเก่าเป็นรหสัใหม่และบนัทึกค่าเป็นของตวั
แปรเดิมโดยเลือกเมนู Transform > Recode > Into Same Variables หรือเปล่ียนรหสัของตวัแปรจาก
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รหสัเก่าเป็นรหสัใหม่และบนัทึกค่าเป็นของตวัแปรใหม่โดยเลือกเมนู Transform > Recode > Into 
Different Variables 
 
ตวัอยา่ง 3.14 จากแฟ้มขอ้มูล file_xy1.sav ใหเ้ปล่ียนค่าของตวัแปร x เป็น 1 ถา้ x < 5 และ เปล่ียนค่า
ของตวัแปร x เป็น 2 ถา้ x ≥ 5 แลว้บนัทึกค่าเป็นของตวัแปร x เช่นเดิม 
 

   
 
ขั้นท่ี 1 เปิดแฟ้มขอ้มูล file_xy1.sav เลือกเมนู Transform > Recode > Into Same 

Variables 

 
 

ขั้นท่ี 2. เลือกตวัแปร x มาไวท่ี้ช่อง Numeric Variables แลว้เลือก Old and New 
Values 
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จะปรากฏหนา้ต่าง Recode into Same Variables: Old and New Values ดงัรูป 

 
 
ในส่วนของ Old Value ให้เลือกการเปล่ียนค่าของตวัแปรเก่า โดยทางเลือกแต่ละ

ทางเลือกมีความหมายดงัน้ี 
1. เปล่ียนค่าแบบ 1 ค่า ต่อ 1 ค่า 
2. เปล่ียนค่า System missing เป็นค่าใหม่ 
3. เปล่ียนค่า System missing หรือค่า Missing ท่ีเราก าหนดไวเ้ป็นค่าใหม่ 
4. เปล่ียนค่าเก่าในช่วงท่ีก าหนดเป็นค่าใหม่ 
5. เปล่ียนค่าเก่าท่ีต ่ากวา่ค่าท่ีก าหนดเป็นค่าใหม่ 
6. เปล่ียนค่าเก่าท่ีสูงกวา่ค่าท่ีก าหนดเป็นค่าใหม่ 
7. เปล่ียนค่าอ่ืนท่ีไม่ไดก้  าหนดไวข้า้งตน้เป็นค่าใหม่ 
ในส่วนของ New Value ให้เลือกการก าหนดค่าใหม่ให้กบัตวัแปรเดิมโดยมี 2 

ทางเลือก คือ Value ซ่ึงเป็นการก าหนดค่าใหม่ท่ีละค่า ส่วน System-missing เป็นการก าหนดค่าใหม่
เป็นค่าสูญหายของระบบ 

 
ขณะน้ีเราตอ้งการ เปล่ียนค่า x เป็น 1 ถา้ x < 5 และเปล่ียนค่า x เป็น 2 ถา้ x ≥ 5 
ขั้นท่ี 6. ในส่วนของ Old Value คลิกท่ี Range และพิมพค์่า 1 และ 4 ในส่วนของ New 

Value คลิก Value และพิมพค์่า 1 ดงัรูป 
 

 
 



 97 

 
 
เลือก Add จะปรากฏเง่ือนไขการเปล่ียนรหสัตวัแปรในช่อง Old -> New ดงัรูป 

 
 

ในส่วนของ Old Value คลิกท่ี Range และพิมพค์่า 5 และ 20 ในส่วนของ New Value 
คลิก Value และพิมพค์่า 2 ดงัรูป 

  
 

เสร็จแลว้คลิก Add จะไดผ้ลบนจอภาพเป็นดงัน้ี 
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คลิก Continue และ OK ตามล าดบั จะไดผ้ลเป็นดงัน้ี 

 
 
ตวัอยา่ง 3.15 จากแฟ้มขอ้มูล file_xy1.sav ใหเ้ปล่ียนค่าของตวัแปร x เป็น 1 ถา้ x < 5 และ เปล่ียนค่า
ของตวัแปร x เป็น 2 ถา้ x ≥ 5 แลว้บนัทึกค่าท่ีเปล่ียนแปลงแลว้เก็บไวท่ี้ตวัแปรใหม่ช่ือ newx 
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ขั้นท่ี 1 เปิดแฟ้มขอ้มูล file_xy1.sav เลือกเมนู Transform > Recode > Into Different 
Variables 

 
 

จะปรากฏหนา้ต่าง Recode into Different Variables ดงัรูป 

 
 
ขั้นท่ี 2. เลือกตวัแปร x มาไวท่ี้ช่อง Input Variable -> Output Variable และพิมพช่ื์อ

ตวัแปรใหม่ newx ในช่อง Output Variable ดงัรูป 
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เสร็จแลว้คลิกท่ี Change จะไดผ้ลบนจอภาพเป็น 

 
 

ขั้นท่ี 3. คลิกท่ี Old and New Values จะปรากฏหน้าต่าง Recode into Different 
Variables: Old and New Values ดงัรูป 

 
 

ด าเนินการตามขั้นท่ี 6 ของตวัอยา่ง 3.14 เลือก OK จะไดผ้ลลพัธ์ ดงัรูป 

 


